Questions/issues on a new build startup

Welcome to HobbyCNC.com Forums General HobbyCNC Questions Questions/issues on a new build startup

Tagged: 

This topic contains 7 replies, has 3 voices, and was last updated by  hen0hlk 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3443

    Vic Caranna
    Participant

    I have just recently completed my build of Brian’s CNC machine with several modifications, some to the drive system. I am using Acme 1/2-10, 2 start, drive screws with anti-backlash nuts which calculates out to 8000 steps per inch. I am using the HobbyCNC: Pro 4 axis BOB, being driven by a Warp9 ESS Smoothstepper and a desktop PC running Mach3. The BOB is set for 1/8 step, and the current is set for 3 amps (.42VDC) on each motor. The setup in Mach3 ‘motor tuning’ is as follows: X and Y axis’ = 8000 steps per inch; velocity = 100; acceleration = 20; Z axis = 8000 steps per inch; velocity = 40; acceleration = 10 (NOTE: the Velocity and Acceleration settings have been set all over the map, so I have not settled on these values as ‘final’).

    My questions/issues are:
    1) An issue that I have seen is that if the motors have been sitting idle for a while, the first set of pulses sent to the 1st motor (like in a homing sequence: Z -> Y -> X; or jogging one of the axis’) whichever motor is first will just sit and whine. I can make this repeat consistently by waiting until I hear the BOB cut the current to the motors (about 10 seconds) and then jog to move one of the axis or hit the ‘Home All’ and it will happen again. According to the Driver board build instructions, under “Idle Current Reduction” (Page 5) the decrease of the current supply to 50% appears to be what’s causing this issue for me. Now, before I go tearing into the board and start making wholesale changes, I have a couple of questions. 1 – what is the risk in just disabling the current reduction function by adding the jumpers to J4? Heat? Lifespan? Other risks? 2 – While I have adjusted the acceleration and velocity all over the map, it didn’t help – are there any other software settings, either in Mach3 or the ESS that I may be missing that will accomplish the same function, i.e., slowing down the initial pulse train?

    2) With my current setup, how do I calculate my maximum IPM rate? It seems that I need this data to correctly figure out my Feed and Speed parameters for cutting various materials. While I know that the steppers are 200 steps per rev, and I have the BOB set at 1/8 step, that this gives me the 8000 steps per inch. I don’t see any way to figure out their maximum RPMs are so that I can accurately calculate what my Inches per Minute should be. Any advice here would be a big help.

    As far as the CNC Machine goes, I upsized the carriages to handle a board 26.5″ wide by 36″ long. This required changes to the base honeycomb frame with a deck that now measures 34″ by 46.6″. I also added structural panel to the back of the Y axis carriage because there was a perceptible flex in the Y axis rail.

    I will be happy to post pictures if anyone is interested.

    #3445

    BrianV
    Keymaster

    If slowing down the acceleration and pulse rate didn’t help – check if there is a pulse width setting in your cam software.

    Disable the current reduction (install J4 on all of the axis). This means the motors will get warmer.

    1/8 microstep is probably overkill. I run 1/1 (no microstep) on my machine, and it whines, but other than that I don’t see any issues. I’d suggest 1/2 or 1/4 microstep IF you have some harmonic resonance or vibrations at specific speeds. Don’t use microstepping in an attempt to increase accuracy – that’s not what it’s for.

    You shouldn’t need to ever “calculate” the IPM. You set your CAM software for number of steps per revolution and number of revolutions per inch. That’s it. When you plan your toolpaths, this is where you specify how fast you want your tool to move/plunge/jog. Your CAM software does the math on the fly.

    BrianV

    #3446

    BrianV
    Keymaster

    From the manual:

    A word of caution is in order. Idle current reduction MAY cause lost steps IF your software settings are very aggressive for the start rate and accel rate. It takes a few microseconds to restore full power when commanded to move from an idle current reduced condition. Experiment a bit with this.

    Can you verify your microstepping jumpers for me? See the MicroStepping FAQ

    Can you send me a screen shot from Mach3 for this setting:

    ALSO, Yes, I would like images. I will post them on my soon to be launched “customer builds” page!

    Thanks, BrianV

    Attachments:
    #3455

    Vic Caranna
    Participant

    Hi Brian –
    I changed the microstepping from 1/8 to 1/4 per your recommendation and reset the “Steps per” in Mach3 to 4000. There are jumpers on J2, J3 and J4 on all 4 axis’. After I added the jumpers to J4, I haven’t seen any non-starts – which has allowed me to get into the “Motor Tuning” more effectively.

    I attached the screen shot of the “Motor Outputs” tab. I do notice mine is different than the shot you posted. Something I should look into?

    I took a bunch of pictures (19) of the (almost) finished CNC machine – would you prefer that I store them either on my Google drive or Dropbox for you grab? Your choice. The reason I said “Almost”, is that I am going to add a dust boot as soon as I can machine it. Already have the Gcode done and ‘air run’ successfully. I’m using CamBam for my CAM program.

    I’ll send you a list of the changes that I made if you want – just let me know.

    Regards,
    Vic

    Attachments:
    #3459

    BrianV
    Keymaster

    Vic,
    Glad you’re up-and-running. I need to spend more time dissecting and fully understanding the behavior of the Idle Current Reduction.

    Your Mach3 Screen looks right – I wanted to make sure you didn’t have Active Low for the step signal.

    BrianV

    #3498

    Vic Caranna
    Participant

    Brian –
    Thanks for the “Customer Build” section – its nice to see what others are doing.

    As a follow-up to your earlier post in this thread about the IPM settings, I played around with it in my CAM software package. In the machining tab, the default speed is set at 30 units. I tried an ‘air cut’ using a value of 100 units – and I thought my machine was going to jump off the table it was shaking so bad as the X and Y axis were galloping along. No way that would have made a decent cut in any material not to mention what it may be doing to my antibacklash nuts! Anyway, I will have to try and find a balance between machine speed and bit sharpness that will work efficiently.

    One other item, since I have disabled the Current Limiting function (J4 jumpers), I have been monitoring the steppers to see if they are overheating. My initial assessment is that they are not any warmer that I experienced with the current limiter active. More on this later as I gather additional data.

    Attachments:
    #3512

    BrianV
    Keymaster

    I recognize that as a CamBam screen. My typical cut is 30ipm, no fuss, no muss. I can go to 48ipm (fast jog), also smooth. I haven’t had the courage to cut any faster. You can see my machine in action on DIY CNC Plans page, under the products tab.

    #5861

    hen0hlk
    Participant

    Vic

    May I ask where did you source your Acme screws from? And what specifically did you use. I’m planning a CNC and I appreciate the insight.

    Thanks again

    H

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Pin It on Pinterest